编程资源搜索
编程资源大全
关注站长
易语言软件源码购买
视频教程播放:易语言多媒体教程
易语言常见问题

学习易语言要什么条件?

易语言是全中文全可视化的编程语言,只要认识汉字、会电脑打字,就可以学习易语言编程。

怎样才能学好易语言?

学会一样事情不难,但是要精通就不容易了,不仅是易语言,其他的编程语言也是一样。要学好,必须能够下苦工夫,用心用力。

看教程时不要快进、跳过,一定要耐心看明白。如果把本页的所有教程都看完、看懂,那编程技术已经很不错了。

为什么我的易语言只有基本组件,没有扩展组件?

易语言的基本组件是系统核心支持库中的组件,易语言默认只安装系统核心支持库。其他支持库可以按以下方法安装:

如果是系统自带的,请通过菜单“工具->支持库配置”,在弹出的窗口中选择你想安装的支持库,然后点击“确认”按钮,你所选择的支持库就会安装到系统中。

如果是安装其他支持库,请先把要安装的支持库文件复制到易语言安装目录的“lib”目录下,再运行易语言,通过菜单“工具->支持库配置”来选择。

怎样更改图标?

更改程序图标:通过菜单“程序->配置”,在弹出的窗口中,点击“设置程序图标”,选择一个ICO文件,则整个程序的图标被设置为你所选择的图标,此方法对整个程序(EXE)有效。

更改窗口图标:选择当前窗口,在“工作夹”的“属性”面板中,找到“图标”一栏,选择一个合适的ICO文件,此方法只对当前窗口有效。

图标文件格式:一个ICO图标文件里,一般应该有16x16、32x32、48x48等多种尺寸的图标。

图标文件制作:可以使用IconWorkshop、AWiconsPro等工具制作,也可以到这里下载现成的图标素材。

无法调试运行?

调试运行时提示:“启动欲调试程序失败,有可能是因为被调试程序需要UAC权限或者其它原因,请以管理员权限启动易语言后重试!”。

首先在易语言IDE的顶部菜单里,选择“工具->系统配置”,找到“存根”,去掉“运行前是否请求管理员权限(UAC)”的选项。

如果还是无法解决,建议关闭杀软,关闭游戏再试。(关闭游戏后需要重新启动系统)

为什么无法编译?

编译时提示:“很抱歉,本易语言版本不支持编译程序”。

这是因为你未购买商业版本的易语言,只能学习、试用,无法编译。

对于初学者来说,无法编译也不影响学习,还没学好基础,不用急着编译。

买了加密狗还是无法编译?

请安装加密狗驱动,并且插入加密狗再运行易语言。

无法静态编译?

需要自行下载链链接器,常见的是VC98linker

下载后再打开“易语言目录\tools\link.ini”文件配置一下。

或者下载易语言静态编译链接器一键安装程序自动配置

各种编译方式有什么区别?

普通编译:发布时必须带上支持库文件(fne、fnr)才能运行。

独立编译:把支持库(fne、fnr)打包进EXE,运行时释放到临时目录(接近自解压的RAR)。

静态编译:把静态支持库(lib)编译进EXE,直接成为一体,不再释放(和VC一样)。

编译为易包:编译成易包(epk)文件,供其他工程调用。简单说易包相当于增强版模块和DLL,适合大型项目或多人协作开发。

用户交流
友情链接
  • 教程下载 |  源码下载 |  工具下载 |  支持库下载 |  模块下载 |  网址导航 |  视频播放 |  常见问题 |  用户交流

    版权所有: 彗星网络  www.IT608.Com  Copyright ©  2003-2015 CometNet .All Rights Reserved

    关注我们: CSDN博客  新浪微博  腾讯微博